Knowledge Base

Video Slave

Dialog Recording Part 2: Importing and Creating Events

Video Slave 3 - Dialog Recording Part 2: Importing and Creating Events

In this article we already showed you what it takes to setup Video Slave and Pro Tools for dialog recording. This article now shows how to import dialog from text files and how to create events from within Video Slave.

Before discussing how to actually record dialog with Video Slave and Pro Tools, we will first look at the different ways to get dialog information inside the application. Basically, there are two ways. You can either import ADR sheets from a list of text based formats such as CSV for example but you can also use Video Slave to create new ADR Cue events right from Pro Tools.

Importing ADR sheets

We will start by showing you how to import ADR sheets. To do so, open Video Slave, load the movies in the playlist you want to import ADR Cues for and click "File" -> "Import ADR/Subtitle File". After choosing a file stored in one of the supported formats (CSV, TAB, TXT, SRT, STL, ADR Studio XML), Video Slave will automatically parse the file and display the information it found in a column-wise manner as in the window shown below:

For each line in the document you're trying to import, Video Slave will create one event. Each event in turn has a couple of properties such as start TC, end TC, cue number, dialog text and possibly more (depending on the input format). In order to know which column is supposed to be mapped to which property of the event to be created, you must map the columns by selecting the correct property in the dropdown menus at the very top of each column. As this can be cumbersome, Video Slave already tries its best to map columns automatically. Still, there will be occasions where it doesn't work for all columns. In this case, you can manually adjust the mapping. If a file to be imported contains information that is not supposed to be imported or can't be mapped to a property of Video Slave's events, you can simply select "- unused -"

We strongly recommend that your ADR cue sheets have a column title in the first line to make it possible for Video Slave to detect the columns' content automatically. If you do, please make sure to check the "Skip first line (check if the file to import contains a header line)" box is checked. Additionally, you can tell Video Slave which kinds of events you want to generate. Generally, this will be ADR cue events but there are also scenarios where you may want to generate e.g. streamer events instead. 

Once the columns are mapped correctly, you can assign the events to the movies listed below. When you click the blue arrow in the middle of the window, Video Slave will try to create events from the data displayed in the table view and assign them to all movies in the list below. In case you have movies with overlapping timecode regions, please select which movies the events should be assigned to by clicking the switches on the left side of each movie in the list below. When you are happy with the assignments, click the "Import Events" button at the bottom of the window to finish the import process.

 

Spotting directly from Pro Tools using Video Slave's list interface

With Video Slave 3, it is now not only possible to import ADR cue sheets from a file, you can also create them easily directly from within Pro Tools. To do so, Video Slave offers two interfaces you can choose from: a list-based interface or a window-based interface. We'll start with the list- interface. Go to Video Slave and open the event list window from the "Window" menu. We suggest to place it either on a second screen or below Pro Tools' edit window as shown below.

 

VS3 ADRRec Windows

 

To spot a new event, just drag a selection in Pro Tools and click the "Add New Event from DAW Selection" button in the list window or choose the corresponding item in the "Event" menu in Video Slave. In the event list window, the button is located on the right side of the window:

 

 

When clicking it, Video Slave will read Pro Tools' input and output selection (please make sure to set your main counters to display timecode) and create a new blank event from it. Video Slave will of course only create events if it the event boundaries are within the start and end TC of the currently loaded movie. After a new event was created, you can edit its properties in the event list. Video Slave will automatically highlight the row of the newly created event so you don't need to search for it. After entering the event related properties, you can go on with the next cue and work yourself through all cues you'd like to add. If you feel like you need to modify the cue's boundaries a little, you have several options. You can use the little buttons displayed in the event list next to each timecode address in the start and end TC column. Alternatively, you can select the event by clicking the row once. This will set the event's start and end TC as selection in Pro Tools. Then, you can modify the selection in Pro Tools and let Video Slave update the event boundaries by clicking the "Update Current Event From DAW Selection" button on the left of the event list window.

 

 

Spotting directly from Pro Tools using Video Slave's DAW Settings Window

If you're not a big fan of lists, you can achieve the same results using Video Slave's sophisticated DAW Settings and Quick Control window. The goal when designing this window was to put the focus on the currently selected event only instead of displaying all events at a time. You can open the window by clicking Window -> DAW Settings and click the "Quick Controls" tab at the top of the window to display the event controls. The window is set to be on top of all other windows by default so you can move it atop your main Pro Tools window for example. You can of course just as well move it to another screen if you prefer.

The process of creating new events is exactly the same as with the list window. Create a timeline selection in Pro Tools and enter the information into the window's event property editor. The update process to modify the event boundary is also exactly the same. This window is just another way of achieving the same results. It's neither inferior nor superior to the list window, its only difference is its focus.

Creating events directly in Video Slave

For the sake of completeness, we'd also like to mention that you can of course also create events directly inside Video Slave. To do so, there are various options. The first is to use one of the options available from the "Events" menu. From there you can create new Streamer (Shortcut: S), ADR Cue (Shortcut: A), Marker (Shortcut: M) or Flutter (Shortcut: F) events with default settings. It is also possible to create events on the fly using these menu items. Alternatively, you can use the "+" in the main window's Visual Events track. Video Slave will open a sheet allowing you to enter the event information. Lastly, you can also create new events in both the list and DAW Settings windows as shown above.

To get the best user experience, we recommend using an external device like the Contour Shuttle Pro 2 and map the functions you need the most to hardware buttons.

ABOUT NLA

FOLLOW US